Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Debian 6 and I followed the Linode guides for setting up a LAMP server. http://library.linode.com/lamp-guides/debian-6-squeeze

I have 1 working domain already, and I just added another one, and it doesn't work for some reason. I followed the steps on the guide to recreate another domain. The DNS for my domain is pointed the server, I even traced it. I don't know what is wrong, and I don't know how to debug it. Apache's documentation says use /usr/local/apache2/bin/httpd -S, but I don't have such a directory.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Start by using /usr/bin/apache2 -S

That's a start as it'll show you which virtualhosts are configured correctly.

share|improve this answer
    
I don't have such a directory/file –  Doug Aug 28 '11 at 17:45
    
Then just type "apache2 -S" –  Jason Berg Aug 28 '11 at 17:46
    
I got: apache2: bad user name ${APACHE_RUN_USER} - Trying to find solution now –  Doug Aug 28 '11 at 17:53
    
Okay, the command works. It shows the 2 websites that I enabled, so it should be configured properly. However, I don't know what's the next step. –  Doug Aug 28 '11 at 17:59
    
Did you reload Apache? As far as I know, the "apache2 -S" command just checks the config files. You need to reload Apache after you're done editing them. Try issuing "apache2 -k restart" and see what happens. –  Jason Berg Aug 29 '11 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.