Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have created backups of AMIs for AWS in the past, but I have a medium instance that is causing me troubles.

When I run uname -m, I get -i686

When I run the full command with this value, I get an error: Unsupported architecture [i686].

If I do uname -a, I see i386 at the end - should I be using i386 as the parameter then? Thanks.

share|improve this question
    
Yes, Amazon refers to AMI's as either 'x86_64' or 'i386'. For example, anytime I need to determine the architecture of an instance I include the following if/else statement in my bash scripts. –  AlanZ Aug 31 '11 at 2:11
    
if [ $(uname -m) = 'x86_64' ]; then arch='x86_64'; else arch='i386'; fi –  AlanZ Aug 31 '11 at 2:12
    
AlanZ I guess mine is i386 then. What happens if you backup to the wrong type? –  skaz Aug 31 '11 at 3:01
    
yes, medium instances are i386. I'm not sure I understand what you mean "backup to the wrong type". Is the instance an EBS or S3 (instance-store) backed instance? I'm guessing EBS and you're referring to taking an EBS Snapshot of the root volume? –  AlanZ Aug 31 '11 at 11:43
    
@Alanz I am backing up instance-store instance. By wrong type I mean that I tried the backup command with both x86_64 and i386 parameters, and they both worked. Will both of these restore correctly? I figured this flag did something to the backup. –  skaz Aug 31 '11 at 15:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.