Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have thousands of "File does not exist" in the apache error logs. The strange thing is that the referer is my website and when you view the source code there is no URL request for /images.

What could be causing this?

[Sun Aug 28 03:15:31 2011] [error] [client] File does not exist: /var/www/oneclickrecruitment/public/jobs, referer:
[Sun Aug 28 04:06:28 2011] [error] [client] File does not exist: /var/www/oneclickrecruitment/public/images, referer:

The big problem here is that I have fail2ban setup with apache-noscript which means that innocent users are getting blocked for just viewing the website.

EDIT: I am still getting the above errors for every visit. Thus the reason for the bounty for helping me solve this problem please.

<VirtualHost *:80>
    DocumentRoot /var/www/oneclickrecruitment/public

    ErrorLog /var/log/apache2/oneclickrecruitment-error.log
    LogLevel warn
    CustomLog /var/log/apache2/oneclickrecruitment-access.log combined

# Redirect for non existent subdomains
<VirtualHost *:80>
    ServerAlias * * * *
    Redirect 301 /
share|improve this question
What is the question here? If the files/folders don't exist you'll get these messages. Do they exist or not? – mailq Aug 29 '11 at 10:49
+1 on incomplete question, you need to give a bit more detail, do the directories exist? What are the links/redirects in your referrer to those directories? – lynxman Aug 29 '11 at 10:50
Does /var/www/oneclickrecruitment/public/images exist? – quanta Aug 29 '11 at 10:52
Sorry, no the files do not exist at: – John Magnolia Aug 29 '11 at 11:49
can you give us the output of ls -l /var/www/oneclickrecruitment/public? – toppledwagon Sep 1 '11 at 17:58
up vote 0 down vote accepted

I was looking through some of your pages and came across a 404 that might be relevant.

It is in your HTML Header:

<link rel="apple-touch-icon" href="/webapp/templates/default/images/apple-icon.png" />

I wonder if that is what is mapping to /var/www/oneclickrecruitment/public/images

I looked at the first page for the .../public/jobs error and I didn't see any errors for media in that directory. I'll try to keep looking for it.

share|improve this answer
Yes that was it thank you. – John Magnolia Sep 7 '11 at 17:39
Did that fix both of the problems? or is the other one still outstanding? – pferate Sep 7 '11 at 19:42
Sadly not no and didn't even solved the error messages. Thanks tho – John Magnolia Sep 8 '11 at 9:27

You have two broken image links in your site code (for the urls you have given in the question) which are,

Could you correct these and check whether the issue still persist.

share|improve this answer
That seems to have solved it. Thank you so much. How did you find these missing images? I looked on the firebug net status and everything returned OK. – John Magnolia Sep 1 '11 at 19:42
I always use . Have a great day! – SparX Sep 1 '11 at 19:48
Sadly this problem has turned, I also get the error:[Thu Sep 01 23:07:57 2011] [error] [client] File does not exist: /var/www/oneclickrecruitment/public/jobs, referer:… – John Magnolia Sep 2 '11 at 8:48

Relative include for a resource? ie: "../images"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.