Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am facing this issue. Please help me.

myr# sudo apt-get install mysql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mysql-server: Depends: mysql-server-5.0 but it is not going to be installed
E: Broken packages
share|improve this question

migrated from stackoverflow.com Aug 29 '11 at 14:55

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers 2

There's been 5 new Ubuntu releases after 8.10, and I doubt it's still supported at all. My guess would be the repositories hosting Ubuntu 8.10 have disappeared and thus your system can't load the packages necessary for the installation.

I would start by upgrading the Ubuntu to 11.04, or at least to the latest LTS-support version which is 10.04.

share|improve this answer
    
"I would start by upgrading the Ubuntu to 11.04." Or at least to the latest LTS-support 10.04 –  feeela Aug 29 '11 at 14:31
add comment

I agree on upgrading your system but firstly you can try this :

sudo apt-get update && sudo apt-get dist-upgrade

(This will upgrade your system with all newest package for your actual Ubuntu version)

Then :

sudo apt-get install mysql-server
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.