Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Suddenly,all of my outlook 2003 clients cannot resolve my Exchange 2010 server. Some of my outlook 2010 clients are experiencing the same issue.

The machines themselves can ping it and resolve it, and some Outlook 2010 clients work correctly.

Before it gets mentioned, yes these clients are configured to use encryption.

Error message when attempting to create new profile "Outlook could not log on. Check to make sure you are connected to the network and..."

share|improve this question
1  
Are the affected users all in a single mailbox database? Has a DAG maybe failed over and you have your CAS servers incorrectly configured? –  Ben Pilbrow Aug 29 '11 at 17:01
    
All users are in the same database. DAG looks good. –  wooz Aug 29 '11 at 17:13
    
OK, I wrote my answer before I saw your comment. It definitely sounds like you have some CAS issues, we just need to find out where. –  Ben Pilbrow Aug 29 '11 at 17:19

2 Answers 2

up vote 1 down vote accepted

Microsoft has an article on how to diagnose RPC issues with Exchange

http://support.microsoft.com/kb/325930

I suspect it's an RPC issue. What's different between the Outlook 2010 clients that connect and those that don't? Is Outlook Anywhere configured on those that do connect? That could be an indication of a possible workaround until you figure out exactly what broke with RPC.

Also check out your network. Do you possibly have a failing switch or NIC (you mentioned the NIC drivers temporarily fixing the problem so this could possibly be your issue).

share|improve this answer

This smells of an incorrectly configured CAS topology. The first thing to do is open Outlook and in the system tray, Shift + Right Click on it and see what servers it is trying to contact. You will see some Domain Controllers, but you should also see some Exchange servers. Verify the servers it is trying to connect to are in fact up, and the required Client Access services are started by running Test-ServiceHealth in the Exchange Management Shell on each CAS server.

If you have a CAS array set up, ensure your mailbox databases are configured to use the FQDN of the CAS array as their RpcClientAccessServer property and that clients are also connecting to the CAS array, as opposed to individual CAS servers.

Also, check if all the affected users are in a single mailbox database. Has the mailbox server failed, is the mailbox database mounted, is it in a DAG which has failed over?

share|improve this answer
    
I thank you for your time! I discovered, however, that the latest NIC drivers for my Exchange box's Intel controller solved the issue. I had discounted this because I had just updated them in July, but with the August driver release everything is running smoothly! Once 8 hours have passed, I should be able to note this in the answer field. –  wooz Aug 29 '11 at 18:21
    
I take that back.. Apparently, Microsoft's updates last night have re-introduced the problem, and uninstalling the updates/reinstalling the driver have not solved it. –  wooz Aug 30 '11 at 15:09
    
Are all the services running fine? I'm not convinced a NIC driver problem would cause only some people to be unable to connect. Could you maybe do some sort of topology diagram so we can better understand your setup? –  Ben Pilbrow Aug 30 '11 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.