Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using CentOS 6, trying desperately to get Wifi working via a ifcfg-wlan0 file and fudging with /etc/wpa_supplicant/wpa_supplicant.conf. I do not have an X server, so I do not want to use the GUI tools.

How can I configure NetworkManager to have WPA2-PSK WiFi on wlan0 with an ESSID of inet_bridge. Ethernet works fine, so I know that my setup isn't completely messed up. Must be done at the command line or with vim.

My wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
    ssid="inet_bridge"
    key_mgmt=WPA-PSK
    proto=WPA RSN
    pairwise=CCMP
    group=CCMP
    psk="thisIsMyAsciiPassword"
}

My ifcfg-wlan0:

DEVICE=wlan0
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.0.253
NETMASK=255.255.255.0
DNS1=192.168.0.99
HWADDR=xx:xx:xx:xx:xx:xx
TYPE=Wireless
share|improve this question
add comment

2 Answers

Well, I don't know how to do this with NetworkManager. However, I would like to point you out to my favorite network client - Wicd. Install it, there is CentOS 6 RPM available. Then start its wicd-ncurses interface and you can set it up once and forget about it. When you are done, disable your NetworkManager service and enable the wicd one. No need to touch the wpa_supplicant service. Wicd keeps its configuration files under /etc/wicd directory and your password will be stored in clear text in file called wireless-settings.conf. However, this file is 0600, owned by root.

share|improve this answer
1  
This seriously should be the official "correct" answer... –  Soviero Mar 11 '12 at 1:29
    
Can you confirm it is still maintained? Their launchpad page suggests no major updates since April 2012. –  BigHomie Jan 10 at 0:58
    
@MDMoore313 - no, I can't. The page you listed has it all. At the bottom of the list there are some newer packages, still 1.7.x though. –  grs Jan 11 at 3:57
add comment
up vote 1 down vote accepted

My problem was that wpa_supplicant was not being started with correct command line arguments. So it was not authenticating with the WPA2 Encrypted Access point because WPA2 was disabled in the supplicant.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.