Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The issue that we are facing now is that Scheduled Synchronization is not working when the task scheduler executes a program for Google Apps.

The program runs as follows when within command prompt:

CD C:\Program Files\Google Apps Directory Sync\

sync-cmd.exe -a -o -c August2011.xml

We are running Windows Server 2008 so the referenced link does not really apply (

We've tried the following in the Windows Task Scheduler with not much luck:

Program/Script: "sync-cmd.exe -a -o -c August2011.xml" Add Arguments: Start in: "C:\Program Files\Google Apps Directory Sync\"

Program/Script: "C:\Program Files\Google Apps Directory Sync\sync-cmd.exe" Add Arguments: "-a -o -c August2011.xml" Start in:

Program/Script: "C:\Program Files\Google Apps Directory Sync\sync-cmd.exe" -a -o -c August2011.xml Add Arguments: Start in:

Which is correct? I wish there was just an advanced button as Google's documentation mentions. I look forward to some assistance on this task.

share|improve this question
up vote 0 down vote accepted

Have you tried placing the two commands "cd" and "sync-cmd.exe" into a batch (.bat) file, then scheduling the batch file to execute?

share|improve this answer
That's what I decided to do and all is working now. Thank you, sometimes another way of thinking can be so helpful. – Sean Aug 30 '11 at 14:17
That's good that it worked out for you. – user48838 Aug 30 '11 at 16:08
@Sean If this answer resolved your issue, please mark it as accepted. – jscott Feb 16 '12 at 0:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.