Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Does anyone have experience fixing NoMachine NX and FreeNX? I am using Ubuntu 11.04, I've successfully installed the NoMachine Client, Node, and Server. I have also successfully generated my own SSH keys and made the necessary changes to my ssh and sshd configuration files. Lastly, I am not behind any firewall or anything like that.

When I attempt to connect to my machine (via my static IP address), the RSA authentication goes through just fine (this is visible if I do an ssh -vv ...) but then the connection just freezes for about 60 seconds and then I get an error that says the connection to my IP address closed, and a NoMachine window pops up that says:

NX> 203 NXSSH running with pid: 15723
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: ***.***.**.*** on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 900 -c, /usr/lib/nx/nxserver, ,  ...
NX> 900 Won't execute arbitrary commands.
NX> 280 Exiting on signal: 15

I cannot find any help with an error like this. I've already tried re-installing NoMachine and FreeNX and using a new RSA key, and it always gives the same result. Like I said above, the output of ssh -vv shows that the RSA authentication is successful and then after that, the connection always freezes.

share|improve this question
add comment

migrated from stackoverflow.com Aug 30 '11 at 5:37

This question came from our site for professional and enthusiast programmers.

3 Answers

Not exactly sure as it's been a few years since I used NX but this seems like your problem:

NX> 208 Using auth method: publickey
NX> 900 -c, /usr/lib/nx/nxserver, ,  ...
NX> 900 Won't execute arbitrary commands.
NX> 280 Exiting on signal: 15

Did you install your SSH keys in your user account?

IIRC, with NX, you cannot do this as the SSH credentials are used to login into a special NX account as the first layer of authentication.

share|improve this answer
add comment

If you are using AllowUsers in sshd then make sure that you are also allowing nx user:

AllowUSers nx ..
share|improve this answer
add comment

Check that you installed and propogated the new keys you generated as in this article:

http://www.nomachine.com/ar/view.php?ar_id=AR01C00126

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.