Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm setting up sendmail and postfix for the first time. I believe it's installed correctly, but I need assistance with the configuration. When I call mail(), I get the following in /var/log/mail.log

Aug 30 06:13:52 ip-10-202-193-59 postfix/pickup[28117]: 866186010F: uid=33 from=<www-data>
Aug 30 06:13:52 ip-10-202-193-59 postfix/cleanup[28125]: 866186010F: message-id=<20110830061352.866186010F@ip-10-202-193-59.ec2.internal> 
Aug 30 06:13:52 ip-10-202-193-59 postfix/qmgr[28118]: 866186010F: from=<>, size=392, nrcpt=1 (queue active)
Aug 30 06:13:52 ip-10-202-193-59 postfix/smtp[28127]: 866186010F: to=<>,[]:25, delay=0.$
Aug 30 06:13:52 ip-10-202-193-59 postfix/qmgr[28118]: 866186010F: removed

The message is never delivered.

My postfix configuration is as follows:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination =, ip-10-202-193-59.ec2.internal, localhost.ec2.internal, localhost
myhostname =
mynetworks = [::ffff:]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = 
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
share|improve this question
up vote 1 down vote accepted

The postfix transaction log looks fine. You might check the "spam" folder on gmail just in case it is misclassified as such (possibly due to your configuration) and wound up there.

share|improve this answer
Wow. Problem solved! Good call. – arby Aug 30 '11 at 7:15
Happens too often... Glad it worked out! – user48838 Aug 30 '11 at 7:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.