Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Every time I try doing unmount /some/fs it says it is busy. The server has gone bye bye; anyone have any ideas?

I have tried:

unmount -f /some/fs
Illegal option

unmount -o force /some/fs
Illegal option

unmount /some/fs
File system is busy
share|improve this question
    
Is umount -l a valid option? Luckily I don't have a Solaris 2.7 machine to check on ;) –  theotherreceive Jun 24 '09 at 6:31

4 Answers 4

up vote 2 down vote accepted

Sometimes this works:

mount /some/fs -o remount,soft
umount -f /some/fs
share|improve this answer
    
When using mount /some/fs -o remount,soft the command hangs and does not return. unmount -f is not an available option in Solaris 2.7. –  another average joe Jun 24 '09 at 1:37
    
You're not going to like the only other option I have for you: rebooting. Unfortunately, when NFS goes away, things get very miserable :( –  MikeyB Jun 24 '09 at 1:49

If there is a reason other than trying to keep things tidy, such as it causing hangs every time you accidentally enter that directory, I wonder if you could mount something else over the top. I'm not sure if lofs is in solaris 2.7 (the mount command I used works in Solaris 10), but you could try just mounting another directory over the top:

mkdir /var/tmp/some_dir
mount -F lofs /var/tmp/some_dir /path/to/nfs/mount

That way you won't have any issues whenever someone tried to mount that directory. You might still hit issues with commands like df though.

If that isn't an optimal solution, you could try setting up a temporary nfs server where it used to be and hope the server will succeed in connecting to it. You could create a VM for it, or even just set up an nfs share on your laptop and change the IP temporarily. Just long enough to make the server think it has a valid nfs mount and unmount it.

This is all sounding a little more work than just rebooting at an opportune time (such as when you install patches) however.

share|improve this answer

Your last entry, "filesystem is busy", implies that there is an open file somewhere on that mount, which is the real cause of your pain. Any chance you can track down that file and kill whatever process is using it?

share|improve this answer

I'm unsure as to whether my answer in Q#75883 applies to Solaris or not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.