Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is it possible to clear the DMI event log (the one that gets partially shown by dmidecode --type 15) from Linux ?

I know it can be cleared from the bios but it is a server in a remote location and I'd like to avoid the downtime of a reboot.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

SEL (System Event Log) can be cleared from Linux. Depending on which interfaces you have available will determine how it can be done.

My supermirco workstation as well as most servers have IPMI. You can check if your system registered an IPMI device with dmidecode.

dmidecode --type 38

Failure to query the interface, does not necessarily mean your system lacks an IPMI interface. Just a quick way to verify if it definitely does.

To use IPMI, install openipmi. You will have to start the service first, which is named differently distro to distro.

to clear, run (w/ su/sudo)

$ ipmitool sel clear

If openipmi does not work, you can also try freeipmi. I have heard freeipmi is very solid and has a really good direct (driverless) KCS or SSIF interface.

once you installed freeipmi, make sure to load i2c-dev and i2c-core with modprobe. You will also need to load your chipset dependant i2c-#DRIVER. For example, i2c-viapro or i2c-i810.

Once you load those modules, try running,

$ ipmi-locate

FreeIPMI, has the command ipmi-sel. Which, in addition to other options, would be run with --clear.

If you are running from a PC that does not support either open or free ipmi, I'm not exactly sure where to go from there.

share|improve this answer
1  
IPMI 1.5 allows to use IPMI via serial or ethernet interface. Only some servers support IPMI 1.5 or later. –  Mircea Vutcovici Sep 1 '11 at 15:55
    
Thanks, and sorry for the delay in accepting! I was under the impression that I did not have an IPMI bmc, but dmidecode proved me wrong, and in the end it was just ipmi_devintf who wasn't loaded, silly module :) works fine with openipmi now. –  b0fh Sep 5 '11 at 14:53
    
Not showing you accepted my answer, normally wouldn't make a big deal about it... but it would be my first! –  TechZilla Sep 9 '11 at 13:42
    
Oops, my mistake... too much coffee, not enough sleep. Fixed. –  b0fh Sep 12 '11 at 1:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.