Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I apologize if this question is rather basic, but it is seems to be too broad to easily find a solution. I am running apache2 on Ubuntu on a VPS with 768MB of RAM. I am also running MySQL on the same machine. However, as my database grew in size, I ran into performance issues. I decided to try MongoDB. MongoDB is hosted on a separate server, so it should not affect anything on the web server. After I moved one of the tables to MongoDB, I did notice an improvement in performance. Last night, I converted more tables to MongoDB. Everything was working fine. However, this morning, the website was not reachable. Restarting apache solved the problem, but within 30 minutes I could not reach the site again.

I checked the apache error log and there was nothing suspicious there. What else should I look at?

Also, I don't even understand why this would be happening. Since I am moving some stuff off the server, there should be fewer issues, not more.

share|improve this question
1  
What's running in Apache? Your application code, not your web server, should be the first place you look. –  Shane Madden Sep 1 '11 at 16:29
    
I understand. However, since restarting Apache solves the problem temporarily, there must be something that is making Apache misbehave. I was hoping there would be a way to find out more specifically what that is. So far, the only way I can tell that something is wrong is by waiting for half hour. –  bigmac Sep 1 '11 at 17:01
    
Restarting Apache will restart what's running under Apache, too - you haven't isolated the issue to Apache, unfortunately. While there's a chance that Apache's not behaving correctly, runaway resource usage is almost guaranteed to be an application problem. What is your application written in, and what module is Apache using to interface with it? –  Shane Madden Sep 1 '11 at 17:15
    
Application is in PHP (with Mod-PHP). –  bigmac Sep 1 '11 at 20:26

1 Answer 1

up vote 0 down vote accepted

Although I doubt is something on Apache, it looks more an application issue you may want to increase LogLevel in Apache, http://httpd.apache.org/docs/2.2/mod/core.html#loglevel If you change it to debug you will get more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.