Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I getting the following error while I am taking SMTP test.

The SMTP server does not accept mails to postmaster@[IP_ADDRESS]. This is a very bad thing, as this address is used by people that don't know your domain name! The reported error is:
550 Requested action not taken: mailbox unavailable or not local

Is it really possible to create an email address with IP address not domain? Or do it have any other meaning? Please tell me how can I fix this error.

share|improve this question
You need to indicate what program is providing your smtp services. Without that information its hard to advise you. – mdpc Sep 1 '11 at 17:55
BTW, what SMTP test are you using? – Zoredache Sep 1 '11 at 17:57 This is the website which gave me the above error and I am using default IIS smtp program to send emails – Karthik Malla Sep 1 '11 at 18:10

1 Answer 1

Yes it is possible to send to mailbox@ip, if you want to strictly conform to the RFCs, then supporting this is required. But in this day and age it is extremely common for this to not be supported.

If you want to strictly follow the RFCs you will have an abuse and postmaster accounts that are read by a human. But if you actually have these accounts and have tried to watch them, you will quickly realize that 99.95% of what you get is SPAM.

Honestly, I would suggest you not worry about it. This is a requirement that not longer applies to normal email usage today. Enabling the functionality will probably result in you getting you more SPAM in your inbox, but will almost certainly not result in any real messages getting accepted that would have been blocked.

share|improve this answer
Well. I guess you forgot to answer to my exact question i.e. how to create this kind of email address. – Karthik Malla Sep 1 '11 at 18:12
It completely depends on the mail server. Since you haven't specified what mail server you are running I cannot answer that. With Exim, you would enable allow_domain_literals. Ref: – Zoredache Sep 1 '11 at 18:13
And in Postfix this is enabled/allowed by default. – mailq Sep 1 '11 at 23:03
@Zoredache - I am using Xmail server for windows. – Karthik Malla Sep 2 '11 at 5:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.