Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed Squid on my laptop and I am successfully blocking all the traffic that I want to block ( websites, protocols etc. ). But I would like to route all the traffic form my LAN ( have just 2 computers in it - and I use Dlink 502T router - I know, an old one). Any ideas how can I do this ?

I have found something like this on the web but this is for Linux http://www.tuxradar.com/answers/432

share|improve this question
    
This is off-topic for StackOverflow. Ask your question on ServerFault.com. –  alexn Apr 14 '11 at 14:40
add comment

migrated from stackoverflow.com Sep 2 '11 at 3:51

This question came from our site for professional and enthusiast programmers.

closed as off topic by Jason Berg, Shane Madden, EEAA, John Gardeniers, MDMarra Feb 13 '12 at 20:20

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 2 down vote accepted

The steps for Windows are basically the same as in the link you posted. You need to:

  1. force all traffic to go through your proxy laptop by setting the default gateway on all the the other machines in your LAN. The default gateway setting is under the network interface properties, IP protocol.
  2. block direct Internet access from the other machines of the LAN by adding firewall rules in the router.

If you are using DHCP for step 1 you may have to tweak the configuration of the default gateway on the router, or if it is not possible, assign fixed IPs to all machines.

share|improve this answer
    
hmmm... you are right but! I have Squid set up on port 3128 and I think that will not work if I set up my laptop's IP as a default gateway on other computers. Maybe I should try to change Squid's port to 80 then ? –  Patryk Apr 14 '11 at 15:34
    
Yes, you need port 80 with the transparent option. –  Venza Apr 15 '11 at 9:00
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.