Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed Windows Server 2003 (64bit)

Because the Administrator password was blank I went to cmd > "net user Administrator newpass"

The command completed successfully.

Logged out, Logged back in. Also rebooted.

I go to control panel > system > remote > enabled remote desktop on this computer

Apply.

Go to Select Remote Users, it says "Administrator already has access" however I cannot login as administrator. So I added it into the list anyway. OK, Apply, OK.

I can connect to the server via RDP and get the login screen (so NOT firewall problem). I enter Administrator with newpass but I cannot login.

I have ensured that both systems have the UK keyboard layout and that the password I am using is the same (I preview it in the username field before moving it to the password field and is the same as it was in cmd.

So RDP is enabled, I can connect, but I cannot login as Administrator for which RDP has been enabled. Rebooted again. Hoping to find a solution to this awfully strange problem.

Thanks Chris

Edit: OK this is really strange, this time I changed the password via Computer Management not CMD and rebooted again. On startup I could not login to the server - im thinking oh crap, iv locked myself out. I RDP and the password works fine. I logout of RDP and try again on the actual server and again it doesn't work. eek. not sure what iv done wrong here ^_^

Edit: For some reason when I was logged in on the server, the keyboard was UK, the RDP login screen is UK, but the actual server login screen seems to have reverted to US.

Edit: The silent ALT+SHIFT trick switches the keyboard between US and UK, now just to ensure UK is the default, I guess by changing the registry ... if anyone has steps for setting the loginn screens default keyboard layout to >UK< that would be usefull.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

[HKEY_USERS.DEFAULT\Keyboard Layout\Preload]

Switched 1 & 2

1 = 809 (UK) 2 = 409 (US)

share|improve this answer
    
will accept this as my answer in 2days or so when SF allows... –  Chris Sep 2 '11 at 11:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.