Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running an emailing system using which I am able to send email. Of course my emails are directly moving to user's spam bin. Strange that I am unable to receive emails from any other domains.

I tool SMTP test and found the below error.

503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server. 

I am running Xmail server for Windows to send and receive emails and my domain is www.softmail.me

If possible please verify my DNS settings and find where the error lies at.

My DNS records follows. Domain purchased from GoDaddy.com

; SOA Record
SOFTMAIL.ME.    3600    IN  SOA ns35.domaincontrol.com. dns.jomax.net (
                2011090100
                28800
                7200
                604800
                86400
                )

; A Records
@   3600    IN  A   65.75.241.26
beta    3600    IN  A   65.75.241.26
accs    3600    IN  A   65.75.241.26
test    3600    IN  A   65.75.241.26
mail    3600    IN  A   65.75.241.26
smtp    3600    IN  A   65.75.241.26
webmail 3600    IN  A   65.75.241.26

; CNAME Records
www 3600    IN  CNAME   @

; MX Records
@   3600    IN  MX  10  mail.softmail.me
@   3600    IN  MX  0   smtp.softmail.me

; TXT Records
@   3600    IN  TXT "v=spf1 a mx ptr mx:mail.softmail.me include:softmail.me include:secureserver.net -all"
beta    3600    IN  TXT "v=spf1 a mx ptr mx:smtp.softmail.me include:softmail.me include:secureserver.net -all"
@   3600    IN  TXT "v=spf1 a mx ptr mx:smtp.softmail.me include:softmail.me include:secureserver.net -all"
key1._domainkey 3600    IN  TXT "k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCgaiG57vsLV8fiIC274NsoDx66O86+rWPBx5aDX6n+1oAKleZhTTV+cZ8eHhroknkgMu3p7njDxTkIqud5ExHlf8m5ymBiJ2seCh/vGy4gMp5g90HVdiTJlHjF7fH5oJzgJ7EsEZf7sPjfHWeDlydXQnpHZtpT5QsmMYAPJWp8XQIDAQAB"
_domainkey  3600    IN  TXT "t=y; o=~;"
july2011._domainkey 3600    IN  TXT "v=DKIM1; p=; s=email; t=s:y"

; NS Records
@   3600    IN  NS  ns35.domaincontrol.com
@   3600    IN  NS  ns36.domaincontrol.com
share|improve this question

2 Answers 2

Two things:

  1. It's not a DNS problem.

  2. A. You're trying to send email THROUGH your server to another domain, and your server doesn't allow unathenticated relaying (which it shouldn't, in which case this is the expected and desired behavior). OR

    B. You're trying to send email TO an internal recipient using an email address which your server isn't configured to be authoratative for, in which case you need to add the domain to the servers accepted/authoratative domains.

share|improve this answer
    
So??? what should I do now? –  Karthik Malla Sep 4 '11 at 13:15
    
Just what the answer said...you need to add your domain to the server so it accepts mail from your domain. –  Bart Silverstrim Sep 4 '11 at 13:21
    
@Bart - To which server do you mean? –  Karthik Malla Sep 4 '11 at 14:01
    
Your mail server. –  Bart Silverstrim Sep 4 '11 at 19:38
1  
@Kars Yes there will be. They use the server as a null-mailer. –  mailq Sep 9 '11 at 9:36

Have you checked your mail client that the settings are configured for authenticating to your SMTP server?

share|improve this answer
    
Yes! Up to yesterday I used to get an error 503: Your mail server requires authentication. But now I fixed that error. Its completely resolved and I believe my SMTP server is authenticating. Is this what you are asking me? or did I mean wrong? –  Karthik Malla Sep 4 '11 at 13:17
    
It sounds like whatever you were using to test needed to authenticate at one point. That's what the one error meant. Later parsing of the problem seemed to point towards your mail server not knowing it was supposed to accept mail from your domain name, and since I didn't come up with that solution I didn't want to steal that answer from the user that did. –  Bart Silverstrim Sep 4 '11 at 13:20
    
Of course even I too don't know the answer. My VPS administrators done it and I payed for service. –  Karthik Malla Sep 4 '11 at 13:45
    
Your VPS administrators installed and configured your email server? –  Bart Silverstrim Sep 4 '11 at 13:56
    
Yes! they did it for me. –  Karthik Malla Sep 4 '11 at 14:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.