Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After upgrade from lenny to wheezy keyboard and mouse don't work in X (keyboard available before it starts). I looked over internet about this issue and found some solutions:

  1. remove xorg.conf (http://forums.debian.net/viewtopic.php?f=7&t=62880)
  2. update udev and base-files (http://forums.debian.net/viewtopic.php?f=6&t=64927&p=376136#p376136)
  3. remove /run directory (http://forums.debian.net/viewtopic.php?f=6&t=64927&p=376136#p376136)
  4. reintall xserver and xorg

But, nothing helped me :( Logs of X-server haven't got any messages about keyboard or mouse errors.

Below you can see configuration of my system:

krestyaninov@xxx# uname -a
Linux xxx 3.0.0-1-686-pae #1 SMP Sat Aug 27 16:41:03 UTC 2011 i686 GNU/Linux

krestyaninov@xxx# dpkg -l |grep udev
ii  libgudev-1.0-0 172-1 GObject-based wrapper library for libudev
ii  libudev0 172-1 libudev shared library
ii  udev 172-1 /dev/ and hotplug management daemon

krestyaninov@xxx# dpkg -l |grep base-files
ii  base-files 6.5 Debian base system miscellaneous files

krestyaninov@xxx# dpkg -l |grep xorg
ii  xorg 1:7.6+8 X.Org X Window System
...
ii  xserver-xorg  1:7.6+8 X.Org X server
share|improve this question
    
You can run through the setup again and see if that helps. dpkg-reconfigure xserver-xorg –  egorgry Sep 2 '11 at 14:32
    
Which video driver (xserver-xorg-video-what) and input drivers (xserver-xorg-input-what) are you using? Also, if you can't type or move the mouse, how do you know that the video card isn't locked up? (can you see a clock ticking or something? ssh in and kill X?) –  DerfK Sep 2 '11 at 14:35
    
2 egorgry: I tried, but it didn't help me –  mikhail Sep 2 '11 at 15:08
    
2 DerfK: I see mouse cursor animation and clock ticking. So, it is not problem of video driver –  mikhail Sep 2 '11 at 15:10
add comment

1 Answer 1

up vote 0 down vote accepted

The problem was that X server don't use udev devices and subtle hinted me on it in log:

(II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.

So, when I pay my attention on these lines and add

Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection

to /etc/X11/xorg.conf problem was solved!

P.S. Thanks to Kubuntu Wiki for info about KDE intput system! :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.