Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I read about how to enable the mod_deflate on my "clean" installation of Apache 2.2.17 on Ubuntu. I found that I should do this in order to enable:

LoadModule deflate_module /usr/lib/apache2/modules/mod_deflate.so

So I went to my /usr/lib/apache2/modules, but didn't find the mod_deflate.so file.

What could the problem be?? Is this file even supposed to be there? Am I doing something wrong?

Thanks!!

share|improve this question

migrated from stackoverflow.com Sep 2 '11 at 14:14

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Probably not doing anything wrong, did you search the system for it, it may not be in the location specified in your tutorial, the modules locations will be distribution specific. for example on my suse box it is here: /usr/lib64/apache2-prefork/mod_deflate.so

-sean

share|improve this answer

Location is the same as on my Ubuntu box, however I use de Debian way of enabling modules in apache server. Look for a symlink inside /etc/apache2/mods-enabled, if not then create the symlink with the a2enmod application or do it manually.

share|improve this answer

You may have already done this but still

Go to the root folder if possible i.e. cd /

Then fire 'find . -name mod_deflate.so' or 'find . -name *deflate.so'

I have got two mod_deflate.so one in apache2 and other in apache2-prefork, I guess from Sean's reply I think I need to select prefork for my suse box as well

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.