Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to enable mixed mode authentication (SQL Server and Windows).

I've tried following these rules but the registry key I need to change is missing...

any ideas on how I can do this?


[EDIT:]

MSDE 2000
Windows Server 2003 x64

MSDE 2000 is part of another program (Ipswitch's WhatsUp 2005) so I'm unable to set any install switches.

share|improve this question
1  
What version of SQL server and windows? –  Zypher Sep 2 '11 at 20:11
    
updated my question with the versions –  Trev Sep 6 '11 at 17:10
add comment

2 Answers 2

If you've not started using MSDE yet, and I'm assuming you're referring to MSDE 2000, then my suggestion would be to uninstall it and reinstall it from the command line using the appropriate install switches to enable mixed mode authentication and whatever additional options you need enabled, such as network protocols.

http://msdn.microsoft.com/en-us/library/aa214935(v=sql.80).aspx

share|improve this answer
    
MSDE is installed as part of another program (Ipswitch's WhatsUp 2005) and I don't think I'm able to set any install switches, if I was this would probably be the correct answer.... updated my question with this info. –  Trev Sep 6 '11 at 17:12
add comment
up vote 0 down vote accepted

Ok, I figured it out from this post

MSDE uses 32-bit registry keys, and on a 64-bit server these keys are stored in a different location in the Registry. They were stored under HKEY_LOCAL_MACHINE\SOFTWARE\ Wow6432Node\Microsoft\MSSQLServer

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.