Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My server uses a non-standard SSH port (not 22) for connections and now I am trying to grab some code from Launchpad and it keeps erroring out because it's trying to connect to the server with my SSH port number rather than the standard port 22. I've searched online for a bit and found ways to specify the port for a standard bazaar URL, such as this:

bzr branch bzr+ssh://user@ip:port/path/to/program

But LaunchPad seems to be slightly different in which I don't know where I'd specify the port.

bzr branch lp:~registry/program/build

I tried putting the :22 after the ~ but that didn't work (still tried to connect on non-standard port). Any idea how I'd grab things from Launchpad through port 22?

(Sorry if this belongs on SU, the guidelines between the two seem rather confusing.)

share|improve this question

closed as off topic by Zoredache, petrus, Michael Hampton, Sirex, Scott Pack Sep 22 '12 at 16:11

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do you have a .ssh/config that is changing the default port you are connecting to? Changing the port the server listens on, should not do anything to the client. –  Zoredache Sep 2 '11 at 22:02

1 Answer 1

up vote 3 down vote accepted

It sure seems like you could just setup an .ssh/config file with a valid entry for the host, and it should be used.

Host {hostname} # you could also use an alias here
  Hostname {ip}
  Port {port}
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.