Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

RVM gives me an error during installation of any version of ruby. Let's take for example ree-1.8.7-head

rasfast@rasfast-home:~$ rvm install ree-1.8.7-head
Installing Ruby from source to: /home/rasfast/.rvm/rubies/ree-1.8.7-head, this may take a while depending on your cpu(s)...

ree-1.8.7-head - #fetching 
Cloning from git://github.com/FooBarWidget/rubyenterpriseedition187-330, this may take a while depending on your connection...
Cloning into /home/rasfast/.rvm/repos/ree-1.8.7-head...
remote: Counting objects: 3307, done.
remote: Compressing objects: 100% (2900/2900), done.
remote: Total 3307 (delta 435), reused 2491 (delta 290)
Receiving objects: 100% (3307/3307), 7.75 MiB | 55 KiB/s, done.
Resolving deltas: 100% (435/435), done.
HEAD is now at e1b23fe Merge remote branch 'upstream/v1_8_7_334'
From git://github.com/FooBarWidget/rubyenterpriseedition187-330
 * branch            master     -> FETCH_HEAD
Already up-to-date.
Copying from repo to src path...
Running autoreconf
ree-1.8.7-head - #configuring 
ERROR: Error running ' ./configure --prefix=/home/rasfast/.rvm/rubies/ree-1.8.7-head   ', please read /home/rasfast/.rvm/log/ree-1.8.7-head/configure.log
ERROR: There has been an error while running configure. Halting the installation.
rasfast@rasfast-home:~$ cat /home/rasfast/.rvm/log/ree-1.8.7-head/configure.log
[2011-09-03 23:21:44]  ./configure --prefix=/home/rasfast/.rvm/rubies/ree-1.8.7-head   
configure: error: cannot run /bin/bash ./config.sub

Could you suggest the next step to resolve the problem?

share|improve this question
add comment

1 Answer

After installation of rvm it is a good idea to check the output of

rvm requirements

which on ubuntu gives something like this:

... skipped some part

bash >= 4.1 required
curl is required
git is required (>= 1.7 recommended)
patch is required (for ree and some ruby-head's).

... skipped some part

Additional Dependencies:
# For Ruby / Ruby HEAD (MRI, Rubinius, & REE), install the following:
ruby: /usr/bin/apt-get install build-essential openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion

If you haven't installed the suggested packages try installing them and after that getting your ruby build.

For 1.8.7 there might be some problems with couple of libraries which might be newer than expected and compilation may fail due to that (e.g openssl, look for the solution at http://beginrescueend.com/packages/openssl/ how to get local rvm openssl installation of needed version)

share|improve this answer
    
Thanks! I'll try to suggestion today –  Konstantin Ras Dec 19 '11 at 6:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.