Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been unable to successfully mount an ext4 formatted drive to any of my EC2 instances. All are running CentOS 5.6 (32 and 64-bit mix) all successfully yum upgraded from one of public RightScale AMIs (originally CentOS 5.4) with some of the Rightscale stuff edited/removed as needed.

The error is always when mounting:

# mount -t ext4 /dev/sdf /test
mount: unknown filesystem type 'ext4'

I've tried installing the latest e2fsprogs and e4fsprogs packages (also compiled from the latest e4fsprogs release) and tried 'mke2fs -t ext4' and 'mke4fs' with the same error every time when mounting. Formatting to ext2 will always mount just fine.

Is there a boot time option I need to change or something missing from the Kernel I can verify or change?

FYI: I installed a local CentOS 5.6 virtualbox instance and can mount an ext4 drive just fine using the same commands, so my assumption is it's something with EC2 or the RightScale image I used to upgrade to CentOS 5.6.

share|improve this question

migrated from stackoverflow.com Sep 4 '11 at 3:09

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I believe you still need the ext4 module loaded in order for this to work:

sudo /sbin/modprobe ext4

Additionally, you can have this module loaded automatically by adding ext4 to /etc/modprobe.conf.

share|improve this answer
    
I think I need to choose a custom Kernel when spinning up a new AMI, the one I'm using is not configured for ext4 :( –  Richard Sep 2 '11 at 1:33
    
CentOS 6 has support for EXT4 built-in, if that helps. –  SpacemanSpiff Sep 4 '11 at 4:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.