Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

mysql does not exist anymore but when i run yum remove mysql it says that the package is available but not marked for installation, i cannot install new mysql because of that, I need to completely delete everything related to it before installing new one, i do not have tables created so don't need to backup anything i tried to use the yum plugin yum-remove-with-leaves didn't work and didn't find any guide to install it properly, anyway i read on forums that it's buggy and should not be installed so I'm searching for other ways to remove mysql completely

and can i do it using sftp?


the output of rpm -qa | grep mysql is



I tried

yum remove mysql
yum remove mysql-server
yum clean all

and it doesn't seem to fix it.

When I run yum install mysql mysql-server or yum install mysql or yum install install mysql-server i would get this

enter image description here

share|improve this question
What is the output of rpm -qa | grep mysql? – quanta Sep 5 '11 at 2:20
@quanta please read my edit – user Sep 5 '11 at 8:29
What happens when you execute yum install mysql-server? – quanta Sep 5 '11 at 8:32
@quanta please read my edit sir – user Sep 5 '11 at 10:12
up vote 6 down vote accepted

yum remove mysql55-libs and try again.

Besides, I saw you used a lot of repos: atomic, dag, epel, rpmforge, livna, ..., it may be the cause of conflicting. In my opinion, atomic and (rpmforge or epel) are enough.

share|improve this answer
ok how to remove the repos that i don't need, 'yum remove dog' or is there another way? – user Sep 5 '11 at 10:39
Open the /etc/yum.repos.d/*.repo file and change enabled=1 to enabled=0. – quanta Sep 5 '11 at 10:45
didn't work, i got a new vps and it's working now, i guess there was something wrong with the server, thanks for your time sir – user Sep 6 '11 at 21:04

Try this:

    yum clean all
    yum install mysql
share|improve this answer
that doesn't seem to fix it – user Sep 5 '11 at 10:12
  1. Execute the following command :

    # rpm -qa | grep mysql

    It will list all installed mysql packages on your system. Eg: mysql-libs-5.1.73-3.el6_5.x86_64

  2. now execute the command:

    # yum remove <name displayed in above step-1>

    Eg: yum remove mysql-libs-5.1.73-3.el6_5.x86_64

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.