Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm building a replica of a production server for migrating it to a Virtual environmnet. I do not want to just copy it as it is a 32 bit CentOS 5, and I upgraded it to CentOS 6 64bit.

I managed to replicate mysql and maintain it as a slave of the production one. The mailserver is managed through ISPConfig2, which I also copied.

The problem now is authentication with pop server. I installed auth-mysql library, and configure it (comparing the configuration files in the production server). I managed to get it loaded on startup, but it seems to be another configuration overriding it:

Sep  5 09:27:10 localhost authdaemond: modules="authmysql", daemons=5
Sep  5 09:27:10 localhost authdaemond: Installing libauthmysql
Sep  5 09:27:11 localhost authdaemond: Installation complete: authmysql
Sep  5 09:27:18 localhost postfix/postfix-script[1502]: starting the Postfix mail system
Sep  5 09:27:18 localhost postfix/master[1503]: daemon started -- version 2.6.6, configuration /etc/postfix
Sep  5 09:27:27 localhost authdaemond: modules="authuserdb authldap authcustom authpipe", daemons=5

Could it be postfix overriding it? It first loads "authmysql", and after that, starts loading "authuserdb authldap authcustom authpipe". I've been trying all the weekend, I even removed auth-ldap configuration files, but I'm now stuck.

When I login via Telnet, it even doesn't try to connect MySQL:

Sep  5 09:41:00 localhost pop3d: Connection, ip=[::1]
Sep  5 09:41:09 localhost authdaemond: ldap_simple_bind_s failed: Can't contact LDAP server
Sep  5 09:41:09 localhost authdaemond: ldap_simple_bind_s failed: Can't contact LDAP server
Sep  5 09:41:09 localhost pop3d: LOGIN FAILED, user=xxx@xxx.com, ip=[::1]
Sep  5 09:41:09 localhost pop3d: authentication error: Input/output error

Any idea on what to try or which configuration file could be doing this would be appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Solved. For any reason there were two configuration files "authdaemonrc" in two different dirs and I wasn't editing the correct one. Modified it, and link the correct libauthmysql.so files, and worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.