Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I suddenly could not RDP into my server after rebooting it. Turned out the Firewall was blocking me, I remotely shut off the firewall service (parallels virtuozzo panel) and was able to RDP in. When I went to add my office IP to the firewall to allow me to connect, it won't launch the control panel unless I enable the Windows Firewall. If I do that, it kicks me off of RDP naturally. So how on earth can I configure this thing?

share|improve this question

closed as off topic by Chris S, Chopper3 Sep 6 '11 at 18:42

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do not cross post. If the Question is on the wrong site we'll move it. –  Chris S Sep 6 '11 at 18:18
    
@ChrisS It seemed to me that it fits on both sites, though probably more relevant here. –  ioSamurai Sep 6 '11 at 21:27
add comment

1 Answer

Here is the solution!

You can also edit the settings on Registry directly (regedit), under HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy. (This even works over the network, assuming Remote Registry is running.)

For Remote Desktop, under the key StandardProfile\GloballyOpenPorts\List add a string value named 3389:TCP with the data 3389:TCP:*:Enabled:Remote Desktop.

Thanks to this fine fellow.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.