Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have PXEBOOT working just fine, but the OS itself isn't booting properly. What's the proper fstab entries? I google and there are many variations and I've tried them all. My image came from a new Fedora 15 install. I've tried using the fstab below as well as removing everything out of it.

My tftpboot parameter ...

append initrd=/images/fedora/dracut.img nousb root=/dev/nfs nfsroot=NFS_SERVER:/admin/linux/fedora/root

NFS Mount ...

/admin/linux/fedora/root *(rw,no_root_squash,sync,no_subtree_check)

Client's fstab ...

none   /proc   proc    defaults    0 0
/dev/nfs   /   nfs defaults    0 0
none   /dev/pts    devpts  defaults    0 0
none   /tmp    tmpfs   defaults    0 0
none   /var/run    tmpfs   defaults    0 0
none   /var/lock   tmpfs   defaults    0 0
none   /var/tmp    tmpfs   defaults    0 0
share|improve this question
    
Can you verify that the NFS mount is mountable from an anonymous user from the PXEBOOT system? Maybe post relevant parts from your NFS exports file. –  pferate Sep 6 '11 at 17:58
    
/admin/linux/fedora/root *(rw,no_root_squash,sync,no_subtree_check) and i would post error messages but there are too many. I can tell you it mainly has to do with the system not being able to mount /. Here's one...`Starting sm-client: can not chdir(/var/spool/clientmqueue/): Permission denied. –  luckytaxi Sep 6 '11 at 17:59
    
It looks like you are missing rw in your tftp kernel parameters. That might explain the permission denied error on starting sendmail. You can try adding just before nfsroot. –  pferate Sep 6 '11 at 18:16
    
I believe I've tried that. ANy idea as to what the client's fstab should look like? –  luckytaxi Sep 6 '11 at 18:24
    
Getting "mount: only root can do that (effective UID is 505). –  luckytaxi Sep 6 '11 at 18:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.