Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I get this when I install the apache on windows:

only one usage of each socket address

is normally permitted. :make_sock: could not bind to address 0.0.0.0:80

Note that I had visual studio 2010 installed on it..and developed an asp.net site on this pc using the local host...

Any way I can install the apache and run it without getting this: http://localhost/

, when I type:

Bad Request (Invalid Hostname)

share|improve this question

migrated from stackoverflow.com Sep 6 '11 at 18:10

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

You are already running another web server on your machine, which is bound to port 80.

Somewhere in your Apache config file, there will be a line that looks like this:

Listen 80

If you change it to this

Listen 8080

It will bind Apache to port 8080, so you can access your Apache web sites like this:

http://localhost:8080/

Alternatively, you reconfigure Visual Studio to use a different HTTP port.

share|improve this answer
    
I could use it with netstat command (by what a read currently) to port 81... the appache has got a folder called conf.. // i changed listen 90 to 8080 ..still doesnt work.. i changed the text file named httpd to what you said –  Dmitry Makovetskiyd Sep 6 '11 at 8:35
    
Edit..: correction..i changed this to : localhost:8081 ...will this setting not make problem?!?? –  Dmitry Makovetskiyd Sep 6 '11 at 8:38
    
There is no reason why using any particular port should cause a problem, as long as another program doesn't try and use it as well. I often use 10080 on machines where one (or more) web servers is already installed. –  DaveRandom Sep 6 '11 at 8:43
    
alright, thanks for your help –  Dmitry Makovetskiyd Sep 6 '11 at 8:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.