Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to copy my ssh key from my local vm to another box, everything seems to work ok, but when I check the remote box the file isnt there...

Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.0 seconds

scp doesnt look it's writing anything, but I have no idea why!

I thought maybe it's because the internal network isnt exposed and maybe it's not able to talk to the remote box through scp, but it seems to be doing some handshaking... When I scp to a box in the network it works fine =/

Why wont scp work here?

I've checked the permissions on the remote box looks ok...

No error messages...

scp -v output

[user] > scp -v my.key.pub www@domain.net:.ssh/
Executing: program /usr/bin/ssh host domain.net, user www, command scp -v -t .ssh/
OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to domain.net [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: loaded 3 keys
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'domain.net' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:11
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
[user] > www@domain.net's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug1: Sending command: scp -v -t .ssh/
Bash Src is loaded!


debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 1 clearing O_NONBLOCK
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.0 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 0
share|improve this question
    
Have you tried giving it an absolute path on the remote end? –  Matt Simmons Sep 6 '11 at 18:51
add comment

2 Answers 2

up vote 4 down vote accepted

What's that "Bash Src is loaded!" in the verbose output? It's coming from your ~/.bashrc, isn't it? Make it go away.

Basically, it's the same as this: Rsync seems incompatible with .bashrc (causes "is your shell clean?") but with scp instead of rsync.

Hey, there's even an entry in the FAQ: http://www.openssh.com/faq.html#2.9

share|improve this answer
    
you rock thank you! –  qodeninja Sep 6 '11 at 20:09
    
this fixed my problem, thank you. I guess bash will load profile and alias on its own for interactive shells so I dont need to source alias in bashrc –  qodeninja Sep 6 '11 at 20:19
    
It's been a long time since I first set this up, but .bash_profile is loaded for interactive shells and .bashrc for non-interactive ones. I apparently source .bashrc inside my .bash_profile, with .bashrc setting the various environmental variables. –  cjc Sep 6 '11 at 20:34
add comment

If you're unable to transfer any files, it's likely due to your .bashrc (or the equivalent) doing things it oughtn't during non-interactive logins (i.e. when rsync'ing, scp'ing, etc); in the bad old days, 'stty' was particularly notorious for causing problems like this. See http://theory.uwinnipeg.ca/localfiles/infofiles/bash/bashref_54.html for some hints on how to check if your shell is interactive or not.

share|improve this answer
    
It would be better to put stuff that emits output into .bash_profile and things that don't emit output into .bashrc, rather than doing conditional checks for the interactive shell. –  cjc Sep 6 '11 at 19:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.