Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have RHEL 6 running Apache and a Django application connected via WSGI. When I run service httpd start, I get a segmentation fault (in my error logs) and it reports something about "Premature end of script headers". However, when I run /usr/sbin/httpd, the site runs without errors and my Django project runs just fine.

What is the difference between these two? Is it possible I accidentally have two installations of Apache on my machine (and how could I tell)?

I'm just trying to make sure this is as clean as possible, and to remove any errors I might have...

share|improve this question

I have determined that it has something to do with the environment variables. When running Apache with the service command, it disables most environment variables - but doing so the other way doesn't. It comes down to how the Django app is written and what variables are needed (globally)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.