Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sorry if this is a silly question.

In server 2008, it is impossible for a user with administrator privileges to run things as an administrator without explicitly commanding it (right click->run as administrator, or properties->always run as administrator). This is not working for us for many reasons. Is there anyway to set everything to run as administrator by default?

share|improve this question
1  
install windows 95? –  x0n Sep 6 '11 at 20:26

2 Answers 2

up vote 5 down vote accepted

Turn off UAC (or disable Admin Approval Mode).

(Note: doing this voids any warranty I may give you as to the security of your server)

share|improve this answer
3  
Indeed, if the reason it's "not working for you" is on of the standard variants on being annoyed at having to click extra things, then don't turn it off. –  Shane Madden Sep 6 '11 at 20:52
    
Even with UNC turned off we still must explicitly command executable to run in administrator mode. –  user833970 Sep 7 '11 at 14:30
    
Disable Admin Approval mode –  squillman Sep 7 '11 at 14:34
    
it looks as if UAC was not actually off and the machines needed a reboot for the setting to take effect. Though disabling admin approval is an excellent alternative. –  user833970 Sep 8 '11 at 1:19

You can try disable Admin Approval Mode.

Click Start, click All Programs, click Accessories, click Run, type secpol.msc in the Open box, and then click OK.

From the Local Security Settings console tree, double-click Local Policies, and then double-click Security Options.

Scroll down and double-click User Account Control: Run all administrators in Admin Approval Mode.

Select the Disabled option, and then click OK.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.