Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to copy a URL link for our companies library system onto all users workstation desktops. I've tried creating a shortcut via Group policy: User Configuration > Preferences > Windows Settings > Shortcuts however from what I can tell, this doesn't work onto Windows 7 machines as they're common desktop directories are different. (Running Server 2008 not R2.)

I've also tried copying the shortcut from a server location to the directory C:\Users\Public\Public Desktop. However I'm running into issues as the Public Desktop folder is a hidden folder. Running a command such as

copy "\\server\folder\link.url" "c:\users\public\public desktop\" does not work as the public desktop folder is hidden, so it just returns a directory not found error.

I have also tried running robocopy \\server\folder\ "c:\users\public\public desktop" link.url This however just results in robocopy creating another non hidden folder 'Public Desktop' next the the hidden one in the 'c:\users\public' folder.

Similarly using the GPO User Configuration > Preferences > Windows Settings > Files to try and copy it in yields no result. For the same reason being the destination folder is a hidden folder.

Is there any way I can manipulate either GPO or some copy/robocopy command to place the file into the preexisting hidden folder for all our Windows 7 workstations.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The problem isn't that it's hidden, it's that you're using the wrong path. You want to copy it to c:\users\public\desktop

share|improve this answer
    
Thanking you. Works like a charm. –  chr Sep 9 '11 at 1:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.