Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I updated the openssh package to version 5.9p2 from source so I can use conditional statements. Running CentOS 5.6 x86.

OpenSSH_5.9p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008

The problem even though ssh -v shows the correct version, when I modify /etc/ssh/sshd_config directives don't seem to take effect. I can even type incorrect syntax in the sshd_config file, just utter gibberish, and when I do service sshd restart I don't see the syntax errors listed.

Am I missing something here?

share|improve this question
1  
When you compiled OpenSSH and make install, where did the binaries go ? Are you sure you are calling the one that you compiled ? updatedb then locate sshd and locate sshd_config. If you didn't pay enough attention to configure options, it could be using the config file from somewhere else (i.e. /usr/local/sshd/etc). –  Torian Sep 7 '11 at 1:53
    
Yeah when I compiled I did: ./configure --prefix=/usr && make && make install should I change that too: ./configure --prefix=/etc && make && make install –  Justin Sep 7 '11 at 1:57
    
Rebuild using the correct --prefix or other configure variables so it is in the normal location. –  polynomial Sep 7 '11 at 2:01
add comment

1 Answer

up vote 4 down vote accepted

When you configure using only --prefix=/usr, it meant that everything got installed into /usr (binaries, configuration, etc.)

If you like to compile things, it is a good practice to always read configure --help first. It will give you hints on how defaults are setup.

share|improve this answer
    
After about 8 tries (sigh), I think this the right configure syntax to override the default CentOS openssh. ./configure --exec-prefix= --prefix=/usr --sysconfdir=/etc/ssh && make && make install –  Justin Sep 7 '11 at 3:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.