Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Pretty sure it doesn't matter but I've had about a dozen OpenVz vps' and never seen this until I bought a Xen server for the first time.

Special characters like « get all funky and look like this: �

What can be done to so the characters display properly? Using Debian

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

How are you connecting to the VPS, via PuTTY for example? If yes, set the encoding to UTF-8 in the settings ("Translations").

If you're connecting from a client via ssh command directly, please show us the output of echo $LANG (both on the client and the server).

share|improve this answer
    
Rx:~# echo $LANG en_US.UTF-8 And I am using putty, but can't seem to find settings -> translations –  Kevin Duke Sep 7 '11 at 18:29
    
when I do echo $LANG on my openVZ vps' I get no output –  Kevin Duke Sep 7 '11 at 18:31
    
Sorry - the PuTTY setting is in Window -> Translation. If your VPS doesn't show anything in $LANG you need to configure the locale via dkpkg-reconfigure locales. –  weeheavy Sep 8 '11 at 8:14
    
Rx:/etc/default# more locale LANG="en_US.UTF-8" –  Kevin Duke Sep 12 '11 at 0:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.