Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a folder on a network drive (X:/) and my WAMP is on C:/. I use WAMPS 'Add an alias' tool and point /bymnew/ to X:/Brief Your Market Integration/data/website. The alias is created and looks like this:

Alias /bymnew/ "x:/Brief Your Market Integration/data/website/" 

<Directory "x:/Brief Your Market Integration/data/website/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order allow,deny
    Allow from all
</Directory>

I have also tried it with the server path:

Alias /bymnew/ "\\jacklogic2\projects\Brief Your Market Integration\data\website" 

<Directory "\\jacklogic2\projects\Brief Your Market Integration\data\website">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order allow,deny
    Allow from all
</Directory>

However, this just causes Apache to not start. It only seems to happen on folders in X:/, as a few folders are already aliased to C:/

share|improve this question
1  
Is X: mounted for the user that Apache is running as? –  Shane Madden Sep 8 '11 at 0:38
    
How can I find this out? httpd.exe is running as SYSTEM, and the X: drive has permissions for Everyone –  rickyduck Sep 8 '11 at 8:34

3 Answers 3

Mapped drives are per-user; your SYSTEM user doesn't see the same drives as the user that you're running as.

Try creating a new user (a service account) with the rights needed to run the Apache service, and set up the mapped drive under that user.

share|improve this answer
Alias /music "X:\Backups\Folders-Files\iTunes\iTunes Music\Music"
<Directory "X:\Backups\Folders-Files\iTunes\iTunes Music\Music">
  Options +Indexes
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>

Consider using \'s not /'s

And don't add a trailing / to the alias.

share|improve this answer
    
Unfortunately this didnt work either –  rickyduck Sep 8 '11 at 8:33
    
Aww. I really thoutht we hat that one in the bag –  U4iK_HaZe Sep 8 '11 at 9:53
    
I wish we did :( –  rickyduck Sep 8 '11 at 9:58
    
My silly iPod doesn't know how to type. I just realized last comment was incorrect in 2 places. Sad. But yes, I'll try to figure out something later today. Maybe we can fix it after all. –  U4iK_HaZe Sep 8 '11 at 11:52
    
If you could that would be great. Serves you right for using an iPod! –  rickyduck Sep 8 '11 at 12:14

You should use forwardslashes or escape any backslashes. You should use the UNC path or make sure the network drive is mapped in the user account used to run the apache service as per the answer by Shane Madden. So:

Alias /bymnew/ "//jacklogic2/projects/Brief Your Market Integration/data/website/" 

<Directory "//jacklogic2/projects/Brief Your Market Integration/data/website/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order allow,deny
    Allow from all
</Directory>

Tip: If you delete the trailing slash from 'Alias /bymnew/' to become 'Alias /bymnew' you can use http://localhost/bymnew instead of http://localhost/bymnew/ to access your aliased directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.