Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a development oracle server in the office that has worked for several months up until Friday, when each and every call started returning after a 20 second delay to my computer.

The delays are always 20 or 21 seconds, so I am assuming each call is timing out on something that is taking exactly 20 seconds.

The delays happen on my computer, and my computer only, all other computers in the office are working as normal.

I have not made any recent changes that should/would effect this service.

Please let me know of any troubleshooting or solutions you can come up with!

Oracle 11g running on redHat.

EDIT: I fixed a problem with DNS and the oracle server not being able to ping my computer, but this problem persists.

EDIT: From what I've found on google, this has something to do with a telnet timing out.

share|improve this question

migrated from stackoverflow.com Sep 7 '11 at 15:38

This question came from our site for professional and enthusiast programmers.

1  
Could there have been a DNS server change, so the first choice your computer goes to is bad, but the fallback works fine, and you can do the connection? –  James Black Sep 7 '11 at 14:44
    
@JamesBlack I was having a DNS problem, but it has been fixed and the oracle DNS has been flushed. Lukas You may be right, I will move the question over. –  Greg Agnew Sep 7 '11 at 14:51

1 Answer 1

Run netstat -tn to see all open connections while it hangs. That might give you an idea.

Run netstat -tn again when the call goes through. The interesting connection(s) will be in the state TIME_WAIT for two minutes.

[EDIT] Now you see all the connections. Check the IP addresses. Are they correct? If not, check your DNS settings.

If the connection doesn't show up quickly during the test, then DNS is the problem. Maybe you're using two host names and one of them doesn't resolve.

If the connection does show up timely, then DNS works. Try telnet <server> <port> from a console. If that hangs for some time, check firewall settings, firewalls between you and the server. Also try to ping the server or connect to a different service (to see whether Oracle is the problem or all connections).

share|improve this answer
    
This has not been of any help. There are plenty of connections with TIME_WAIT for extended times. –  Greg Agnew Sep 7 '11 at 17:23
    
Run it once before the test, once during the test and once after. Sort the results and compare them. That should bring the number down to just a couple of connections. –  Aaron Digulla Sep 8 '11 at 14:36
    
... I know which connection it is. I need to know why the delay is happening. –  Greg Agnew Sep 9 '11 at 19:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.