Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a policy of disallowing scripts and ActiveX controls to run on in IE our network (instead opting to use Firefox) thereby skirting a number of security issues dating back to IE 6, but we recently decided to purchase QuickBooks, which requires IE, scripts, and ActiveX controls. We aren't about to change our Firefox policy now, but we do need to get IE to play nice with QuickBooks without reducing IE security in general. So far our set up is as follows:

Trusted Sites Zone setting

  • Enable "Allow active scripting"
  • Enable "Run ActiveX controls and plugins"

The remaining settings are not configured. I've set the same settings to "prompt" for the internet zone for testing purposes, and I put the following in the "Site to Zone Assignment List":

Site to Zone Assignment List

  • *.intuit.com : 2
  • *.quickbooks.com : 2
  • *.intuitmarket.com : 2
  • *.payroll.com : 2

This has eliminated the majority of issues we have with prompts while using QuickBooks, but we are still getting prompts on a number of screens, and I can't figure out what could be causing them. For example, Quickbooks Forms Customization (I need to load the URL 2x before the forms page loads in IE) gives me both prompts:

  • "Scripts are usually safe. Do you want to allow scripts to run?"
  • "Do you want to allow software such as ActiveX controls and plug-ins to run?"

I've discussed the issue with QuickBooks support, but their support team was unhelpful. How can I get rid of the prompts?

share|improve this question

1 Answer 1

Well even if the site is in the trusted sites list, you need to either adjust the security setting: Tools>options>security settings> low/medium/high to allow scripts without warning. Click "custom" then look under the category of ActiveX controls. There's an option not to show warning for both previusly used and new scripts. That will resolve the "do you trust my script" error in IE.

share|improve this answer
    
"Allow previously unused ActiveX controls to run without prompt" is already set to Enable; I'm not sure what other option you are referring to. –  JohnB Sep 7 '11 at 21:19
1  
I didn't know you had that set already. Are there any related options below it that may come in use in solving the issue? I really thought that would work. –  U4iK_HaZe Sep 7 '11 at 21:21
    
What is the name of the other ActiveX control setting you mentioned? I couldn't find it, so I'm not sure what it's set to. It sounds like what I'm looking for. –  JohnB Sep 7 '11 at 21:29
    
Yes, here's a bunch of screenshots of the menu: u4ik.us/public/activex.pdf –  U4iK_HaZe Sep 7 '11 at 21:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.