Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i got an error when trying to install apc in xampp (windows).

c:\xampp\php>pecl install apc
downloading APC-3.1.9.tgz ...
Starting to download APC-3.1.9.tgz (155,540 bytes)
.................................done: 155,540 bytes
54 source files, building
WARNING: php_bin C:\xampp\php\php.exe appears to have a suffix \php.exe, but con
fig variable php_suffix does not match
ERROR: The DSP APC.dsp does not exist.

c:\xampp\php>

help me please how to get apc.dsp.. thx.

share|improve this question

migrated from stackoverflow.com Sep 7 '11 at 20:20

This question came from our site for professional and enthusiast programmers.

1  
    
i have follow that answer before.. i download the php_apc.dll and put it in /ext after that add some line of code in php.ini.. but it still cannot install apc in my local server. :( –  MRWBSN Sep 7 '11 at 19:40

1 Answer 1

up vote 2 down vote accepted

Its windows I guess (from c:\xampp\php). So pecl would not work as it compiles the extension and for it needs, a c compiler, php headers and other stuff.

The easiest way is to download a prebuilt dll and add it to your extensions dir. I have also installed xampp on my win dev machine and done the same thing.

Grab the appropriate dll from http://downloads.php.net/pierre/
For PHP 5.3 php_apc-3.1.5-5.3-vc6-x86.zip

DO NOT GET the nts version

If you have the latest version of XAMPP you would need the PHP 5.3 one

extract the dll to c:\xampp\php\ext directory
then add following line to your php.ini which is under c:\xampp\php

extension=php_apc.dll

Note: This workd fine with XAMPP 1.7.4, but does not work with XAMPP 1.7.3 . There is a bundled php_apc.dll (version 3.1.3p) which works just fine. SO which XAMPP version do you have ? (you get the version when you open localhost in your browser

share|improve this answer
    
thx.. ur help is very useful.. :D –  MRWBSN Sep 7 '11 at 20:24
    
I unable to find php_apc-3.1.5-5.3-vc6-x86.zip file.it takes me to 404 –  gowri May 16 '12 at 12:40
    
@gowri it seems Pierre is only hosting the latest version now which is built on VC9, which wont be compatible with old versions of XAMPP (before 1.7.7) which has PHP built from VC6. So for now I'd say either try to use the latest php_apc-3.1.10-5.3-vc9-x86.zip from the downloads page and see if it works or stick with the one provided with XAMPP –  danishgoel May 16 '12 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.