Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an installation of Windows Server 2008 (not R2), and I was previously running Remote Desktop via the Terminal Services 120 day free license. That has since expired, and I un-installed the Terminal Services Role, I also believe that you are able to run two instances of remote desktop without needing to pay for the terminal services licence (all I really want is one).

I am unable to remote desktop to the machine, and am not sure where the problem lies... I know that the firewall has been turned off (and port 3389 is open), and I've enabled Remote Desktop under the system properties.

I am using the Remote Desktop Connection for Mac client from within the network, and the message I get is: "You were disconnected from the Windows-based computer because of network problems". When I try using "telnet [server IP] 3389" the response is "Trying [server IP]... Connection refused, unable to connect to remote host". I never make it to a login screen.

Can anyone help point me in the right direction to figure out how to get the Remote Desktop on the machine?

share|improve this question
1  
So what is the actual problem? Are you not able to RDP into the machine or just that you aren't seeing something in the services window? –  Zoredache Sep 8 '11 at 2:38
    
Well, I can't RDP to the machine, and I assumed it was because I couldn't find RDP in the services window, but thanks to the answer, I'm realizing there is in fact a much larger difference between RDP in W2K8 and W2K8R2 –  Brett Sep 8 '11 at 12:13
2  
The only difference is in the name. Both use the same underlying technology. One is called Terminal Services (W2K8) and the other is called Remote Dekstop Services (W2K8R2), other than that they're the same thing. –  joeqwerty Sep 8 '11 at 12:46

3 Answers 3

Remote Desktop Services is not called Remote Desktop Services in W2K8, it's called Terminal Services. Check for the existence of the Terminal Services service and make sure it's started.

User session host mode and management mode both use the same underlying service and protocol; TS service in W2K8 or RDS service in W2K8R2 and the RDP protocol, the difference is in the mode of operation and in the license requirements.

share|improve this answer
    
Well played yourself. How could I not +1 this? I'm pretty sure I'd say the exact same thing :-) –  Jason Berg Sep 8 '11 at 3:27
    
You did say the same thing. It's like we're brothers from different mothers! ;) –  joeqwerty Sep 8 '11 at 3:29
    
So, two points of confusion: 1) Can I use Remote Desktop/Terminal Services without a license (beyond the 120 day trial, and for 2 or less users)? 2) What Roles do I need installed to do that? –  Brett Sep 8 '11 at 12:20
1  
You can use Remote Desktop for Administration with no TS licenses. This does not require that the TS role is installed, the only things required are to have remote desktop connections enabled (System Properties|Remote tab), that the TS service is running, and that the appropriate user is a member of the local Remote Desktop users group. Take note that what you're asking is a nuance of the licensing requirements/limitations... using Remote Desktop for Administration to connect to the server and run productivity applications (MS Office, etc.) is probably a violation of the EULA. –  joeqwerty Sep 8 '11 at 12:38
1  
Run netstat - a -n from a command prompt and verify that the server is listening on port 3389. –  joeqwerty Sep 8 '11 at 16:09

In Windows Server 2008 (not R2) the service is called Terminal Services, not Remote Desktop Services (that was changed in R2). If that is started, make sure terminal services connections are allowed in system properties, make sure your firewall allows TCP port 3389, and make sure the RDS role is not installed.

share|improve this answer
    
Curses. We posted very similar answers at the same time... Well played, Mr. Berg. :) –  joeqwerty Sep 8 '11 at 3:26
    
I've made sure that the system properties allow connections, and the firewall allows connections, when you say "RDS role not installed", do you mean Terminal Server role? I am at a loss for what else to try in order to get it working... –  Brett Sep 8 '11 at 12:22
2  
Yes. The terminal server role. That should NOT be installed. If it is, it requires a licensing server. If it isn't, the terminal services service is still installed, but running in remote administration role. –  Jason Berg Sep 8 '11 at 14:06
1  
Sorry...clarification...can you telnet to port 3389 from the server to 127.0.0.1? –  Jason Berg Sep 8 '11 at 17:15
1  
Did the port get changed? Check HKLM\System\CurrentControlSet\Control\TerminalServer\Winstations\RDP-TCP\PortNum‌​ber –  Jason Berg Sep 8 '11 at 19:03

When you attempt to RDP into the server, what do you get as a response?

Does it say it cant find an RDP (Terminal Server) or does it get in and not take your username and password?

I only ask this because you never actually said and nobody else asked it. Jason and Joe are both right about the requirements though! ;)

Also, for arguments sake, are you RDPing from within your network or outside, if from outside, try from inside to see if you get the same results.

HTH

share|improve this answer
    
I'll update the question with answers to your questions, thanks for chiming in! –  Brett Sep 8 '11 at 16:04
    
This is strange, you have everything set up correctly as I can tell. For arguements sake, disable the windows firewall long enough to do a test with netstat as well as telnet and a test RDP session and see what you get. If it works you know something is wrong in the firewall. Otherwise it's windows itself. BTW, when you RDP are you using the Servers name or the IP? –  Tom Sep 9 '11 at 16:09
    
I've actually had the Firewall disabled for quite some time (and on top of being disabled, I've opened the RDP port). I am using the Server's IP rather than name, and I regularly share drives with the server via IP/FolderName –  Brett Sep 12 '11 at 12:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.