Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu server 10.04 64-bit.

What I've tried:

  • apt-get. doesn't know of it.
  • downloading rpm from here and converting with alien

    dpkg-gencontrol: error: current host architecture 'amd64' does not appear in package's architecture list (i386)

share|improve this question
    
Why do you need ntpstat? Isn't ntpq -p appropriate? –  mailq Sep 8 '11 at 14:51
    
I just need the 0/1 exit code that ntpstat provides for our app monitoring system. I already have this working on CentOS and I'm trying to reuse it. –  mcqwerty Sep 8 '11 at 18:18

2 Answers 2

not a very good way, but it will do:

download the source rpm
rpm2cpio ntpstat-0.2-1.src.rpm | cpio -idmv
unpack the tgz
make && make install

but this is such a small utility, maybe save yourselve the hassle and use another tool that comes with ubuntu.

share|improve this answer
    
That works, thanks. Modern package managers have spoiled me. –  mcqwerty Sep 8 '11 at 18:13

Following jojoo's answer, you should be able to run something like "ntpdc -c sysinfo" or "ntpdc -c peers" to get similar information. It depends on what you're trying to do.

share|improve this answer
    
I need to return a simple true/false value to our app monitoring software. That seems to be ntpstat's raison d'etre. Everything else I've tried is too heavyweight. Thanks –  mcqwerty Sep 8 '11 at 18:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.