Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So i have a server that has locked up twice recently.

What i want to do is catch any kernel panic/oops written to the serial console. I can ssh in and start the VSP and i'm running my SSH session in bash using script so anything written to the console should be logged by script.

The problem is iLO times-out and closes the SSH session.

A quick look in the web interface shows there is an iLO idle timeout but that can only bet set to max 120 minutes and not disabled.

Is there any way to disable iLO closing the SSH session so i can effectively log whats put out over the virtual serial port for some time, and hopefully catch what ever panic/oops is spat out at these seemingly random lockups.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Are you seeing anything in the system's IML logs? Do you have the management agents installed for the hardware?

What specific OS and model of ProLiant server are you using? If you have the agents installed, you should be getting some information relevant to the lockups or possibly tripping the ASR watchdog timer.

For the VSP. have you made the necessary changes to the kernel command line and Grub to output to the console?

For ILO, the model and firmware revision makes a difference. Current ILO2 and ILO3 firmware allows for an Infinite idle timeout under Access Options.

enter image description here

share|improve this answer
    
That looks to be the trick then. Firmware update should allow the connection to stay open. grub and login console are configured correctly the only issue is that iLO closes the connection. –  Steven Williamson Sep 8 '11 at 22:27
    
If you're coming in remotely and using PuTTY, you can also try the keepalive mentioned in another comment. I'd be very interested in whether you're getting anything useful in the output from the HP agents, though. –  ewwhite Sep 8 '11 at 22:32

If you can use PuTTY, maybe you can prevent a time out from occurring...

Putty Configuration

share|improve this answer

I'm not sure if the ilo's SSH implementation supports it but using the openssh client and setting ServerAliveInterval may help. It defaults to 0. I use it to keep my ssh connections active to prevent nat table timer timeouts. In ~/.ssh/config put:

ServerAliveInterval 60
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.