Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My raid 10 - used for / - has failed for my Ubuntu box.

I replaced the bad disk and I am trying to reassemble the raid from the initramfs menu. I have tried starting the degraded Raid and using the recovery startup option

When I run the mdadm --assemble /dev/md1 (devices) command it tell me that the first devices is busy or not accessible. However I can run mdadm --examine on the device in question

any ideas?

share|improve this question
Please include the output of 'mdadm --detail /dev/md1'. Also, could it be that the array was assembled successfully, but wasn't started? If that happened, 'mdadm --run /dev/md1' may get the array online in degraded mode. – Slartibartfast Sep 9 '11 at 5:44
The output is /dev/md1 does not appear to be active. – ckliborn Sep 9 '11 at 17:01
up vote 1 down vote accepted

If you haven't figured this out already, you would almost certainly be better off booting off a livecd and repairing things. Initramfs provides a very limited environment. It is much easier to repair things from more complete system.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.