Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I added User-friendly URL using IIS URL Rewrite Module 2.0 i got this server error 500. I followed the guide on official MS learn iis page.

I noticed when I unchecked following option "Create corresponding outbound rewrite rule"

enter image description here

everything works fine, but I need that option to be enabled. With this option all I got is server error 500. What am I doing wrong? This article didn't help me.

share|improve this question
I looked at Failed Request Log and saw this message "Outbound rewrite rules cannot be applied when the content of the HTTP response is encoded ("gzip")." Seems like I must turn off compression on iis –  nemke Sep 9 '11 at 11:39

1 Answer 1

Nice troubleshooting. Yes, compression clashes with outgoing URL Rewrite rules. Here's a link with instructions on how you can get the two working together:

share|improve this answer
Yes, I found that link also and it helped me. –  nemke Sep 11 '11 at 7:12
I cound find the answer there. It says about ``HTTP Error 500.52 - URL Rewrite Module Error.` But I have got `500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed.… –  Peretz Jun 12 at 15:57
@Peretz, that could be the same error. Your browser may not show the sub status, so it may only show the 500 error. But it could be any number of other causes too. Turning off compression and testing is a good start. –  Scott Forsyth - MVP Jun 12 at 21:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.