Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have two Sharp MX-2310U network printers in our office building. They're both in the same subnet, and both set up in the print services console on our file & print box (Server 2008) with the standard Sharp postscript driver. Energy saving settings are identical for both units, and yet one of them is showing up as "offline", both on the print server and to any client PCs that it's set up on (a mixture of XP and Win7 clients).

The weird part is, jobs that get sent to the "offline" printer still get printed! Does anyone have any idea why this might be? It's not much of a problem, as most of my users don't even notice the status, but it's definitely bugging me.

share|improve this question
    
Sounds like you covered your bases, is SNMP disabled on one of them by chance? Maybe the driver is trying to use that to poll printer status. –  SpacemanSpiff Sep 9 '11 at 13:53
    
I was going to mention this as well. We had the same problem and it turns out that because in the printer configuration we had changed the SNMP community that it was using, but by default Windows 7 had enabled SNMP monitoring for the printer and was using the public community. So once we had changed the community on the printer side, that SNMP connection was no longer happening, so Windows marked it as "offline" –  Safado Sep 9 '11 at 14:12
add comment

1 Answer

up vote 2 down vote accepted

As mentioned in the comments, check the SNMP setting. In Windows 7..

  1. Go to your devices list, right click the printer and select "Printer Properties"
  2. Click on the ports tab
  3. Find the port that's being used (assuming you did the 'standard tcp/ip port' option when setting up the printer) and click Configure Port
  4. At the bottom of the window is the SNMP Status Enabled checkbox.

In my case, I changed the SNMP community. In your case, just try disabling it and see if that helps.

share|improve this answer
    
OK, that's weird; SNMP was enabled on both printers, with a standard community strink of "public". I disabled SNMP on both printers at the print console, and now they're both listed as "online". Thanks for the suggestion. –  RainyRat Sep 9 '11 at 14:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.