Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My main virtual machine crashed today. More specifically, the Windows7 host crashed while the VM was transferring files (very slowly) to a flash drive. I'm running Ubuntu 10.04 LTS - Lucid Lynx in VMware (not sure if it is VMware Player, esx, or what. I downloaded it for free about a year ago) as a testing webserver. Now the VM will not boot past the 1st 2-3 lines. Then it does nothing at all. I waited about 30 minutes one time.

Usually it says this:

fsck from util-linux-ng 2.17.2
/dev/sda1: clean, 652189/6373376 files, 14459048/25464832 blocks

One time it said this:

fsck from util-linux-ng 2.17.2
/dev/sda1 has been mounted 27 times without being checked, check forced.
/dev/sda1: clean, 652189/6373376 files, 14459049/25464832 blocks

[Note: aside from the extra line, the only difference is the number of blocks in the numerator]

I have a bunch of custom php code on there. several mysql databases, and I've made lots of tweaks to the system that I would hate to lose.

To get into Recovery mode, I tried pressing and holding the -shift- key while booting up the VM, to no effect. I've also tried pressing -escape- a bunch of times. I've tried this on working VMs and it doesn't work there either. The only install where I get that option is the one I just did an hour ago, and it comes up automatically, without any key presses.

As I mentioned, the host system crashed while the VM was transferring files to a flash drive. The flash drive is special because I created an entry for it in fstab and it's mounted on every boot. The flash drive still works, by the way.

Does anyone know how I can fix this? One positive is that I now have access to the disk through another VM and all the files seem to be fine. Are there any particular files I should look at or modify to fix this?

share|improve this question
up vote 1 down vote accepted

I'm not sure what happened exactly, but this is what I did and it worked.

  1. I created a new virtual machine with its own small virtual hard drive (only 8GB).
  2. I added the old VM's 100GB virtual hard drive as a secondary drive to the new machine.
  3. I navigated to /etc/fstab in the 100GB hard drive and commented out the line that mounted the flash drive as a permanent disk (I'll put the line at the bottom of this post in case it's of any interest to anyone).
  4. I closed down the new VM, freeing up the old disk, and started up the old VM.
  5. It started up without any problem. I went to /etc/fstab and uncommented the line, just to see what would happen.
  6. I restarted the old VM and lo and behold, it booted up just fine, and the flash drive mounted without any problems.

Conclusion: I'm going to theorize that when the Windows7 host crashed it screwed something up in the relation between VM and flash drive. It seems like commenting the line in fstab was enough for the VM to get its bearings, and remounting was not a problem. This is probably a one-in-a-million occurrence but maybe this will help somebody else.

Here's the no-longer-offending line in fstab, for reference:

UUID=A6F0XXXXXXXXXXX /var/images     ntfs   rw,users,uid=1000,gid=1000,dmask=006,fmask=133,utf8      0          0
share|improve this answer
You can accept your own answers, and I would recommend you do so in this instance since you solved your own problem. – Ben Pilbrow Sep 11 '11 at 14:29

I would assume you are using VMware Player as the question is tagged with it. Here is what to do:

  • shutdown your VMware Player and connect the flash drive to the host;
  • now start again the vmplayer and go to the virtual machine settings. Check for the flash drive and make sure it is connected on power on;
  • boot up your virtual machine;
  • to go in Recovery Mode you need to invoke the GRUB prompt. As the virtual machine is booting you have to be very quick and click on its window. Then hold Shift and GRUB will show up. You could test if you are in the virtual machine application window if you can go to its BIOS. I think F2 is the button for it.

What you are posting about fsck is actually good sign. Shows no errors. I suspect if you connect the flash drive as I described you would be able to boot again just fine, without Recovery Mode.

share|improve this answer
the flash drive is not the boot disk though. I don't know why it would be required to boot the machine. Now that I can access the filesystem, I'll try removing it from fstab and see if that helps. I tried holding shift, I tried pressing down repeatedly. I restart the machine, click to direct input to it, and start doing one or the other immediately. It doesn't work By the way, it says "VMware Remote Console" on the window I use to access the machines. – Buttle Butkus Sep 10 '11 at 5:54
Thanks for your suggestions. I was able to fix it and posted my solution below. I still can't get into recovery, though, so perhaps it is time to upgrade this system. – Buttle Butkus Sep 10 '11 at 22:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.