Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 10.04.3 LTS. I have a NAS using CIFS protocol. I have mounted a share. I am not using fstab at all. Running mount yields the following:

// on /home/s3backup/S3Backup/mnt/FOO type cifs (ro,mand)

When I attempt to unmount it I get the following:

$ sudo umount mnt/FOO           
This utility only unmounts cifs filesystems.
This utility only unmounts cifs filesystems.

I also tried the -l option and it yielded the same results. Any thoughts?


share|improve this question
How about sudo umount /home/s3backup/S3Backup/mnt/FOO? – quanta Sep 10 '11 at 12:09
Huh, there's a bug report that sounds vaguely like that: but the report seems to go nowhere. – cjc Sep 10 '11 at 14:24

I had this same problem on CentOS 5.4 and found a workaround in a RedHat bug report, which recommended using -i which tells it to not use the umount.<filesystem> helper.

In your case, just run

umount -i /home/s3backup/S3Backup/mnt/FOO

This worked, although it will write the following to stderr:

umount: // not found
umount: /home/s3backup/S3Backup/mnt/FOO: not mounted
umount: // not found
umount: /home/s3backup/S3Backup/mnt/FOO: not mounted
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.