Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Every time I try and connect to a remote SQLServer Express instance on my AWS server I get a network or instance specific error.

What I have tried so far:

I ensured that the Security Group applied to the instance has an inbound rule for Port 1433 for all source connections (0.0.0.0/0)

I initially added an exception to the Windows Firewall for TCP 1433 and eventually disabled Windows Firewall altogether to take that out of the equation. Currently it is still disabled.

I assumed I would need a public IP address so I assigned an Elastic IP to the instance. I can RDP into the server using this Elastic IP so I know the association is good.

I enabled TCP as a client connection protocol for the SQL Server instance.

When I RDP into the server and do an IPCONFIG /ALL I assumed I would see the IP address to to be the same as the Elastic IP assigned but that is not the case, I still see the private internal IP address, I'm not sure if this is part of my problem as you see from my local connection tests below.

When remoted into the server I can successfully connect to SQL Server Management Studio uwing the local loopback address + instance name: 127.0.0.1\SQLEXPRESS. I can also successfully connect to SSMS using the private IP + instance name: xxx.xxx.xxx.xxx\SQLEXPRESS. This would seem to indicate that the TCP client protocol for SQLServer is enabled and working normally. However when I try and connect SSMS locally but using my Elastic IP address + instance name I get the same network connectivity error I get when I attempt to connect from my local PC remotely.

So even though I can establish an RDP connection to the server using my Elastic IP address it appears the Elastic IP isn't being associated internally or with SQL Server.

Any ideas?

share|improve this question

2 Answers 2

You actually need to enable Remote Tcp/IP connectivity in SQL Express. by default, every type of remote connectivity is disabled. you can enable it through this article: http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/ or

http://www.datamasker.com/SSE2005_NetworkCfg.htm

share|improve this answer

Set inbound rules for AWS

TCP port 1433 But with UDP port is 1434

With two rules with port 1433, public IP can not connect to SQL server instance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.