Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 addresses one on eth0 one on eth0.1. eth0.1 was created like this:

ip link add link eth0 name eth0.1 type macvlan

dhclient eth0.1 does not get an address, even though eth0.1 does even after assigning the IP manually, I cannot ping between eth0 and eth0.1

I tried Brigding:

# brctl addbr bridge
# brctl addif eth0 bridge
# brctl addif bridge eth0
# brctl addif bridge eth0.1
# brctl show
bridge name bridge id       STP enabled interfaces
bridge      8000.080027b37d2f   no  eth0
                            eth0.1
# bridge showmacs bridge
port no mac addr        is local?   ageing timer
 1  08:00:27:b3:7d:2f   yes        0.00
 1  52:54:00:12:35:00   no        44.45
 2  d2:b2:3a:79:9c:2c   yes        0.00

still can't ping between them.. What do I do?

edit: can't get an IP from dhclient either.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Possibly a trivial omission: Did you do

ip link set eth0.1 up

after creating it?

share|improve this answer
    
yep ifconfig shows all interfaces up. –  user916499 Sep 11 '11 at 5:18
    
Hm... Some ideas: 1) Skip brctl addif eth0 bridge, 2) Change the name from eth0.1 to e.g. eth0mv1 (maybe something doesn't like ifconfig alias-like name connected with macvlan device). 3) Show output of ip addr show. 4) How do you test pinging between the interfaces? –  Paweł Brodacki Sep 11 '11 at 5:28
    
well.. rebooted, tried 1 and 2. something seems to be working.. I'll update after I get some sleep.... –  user916499 Sep 11 '11 at 6:28
    
Now I have a new problem but I'll ask it in a separate post. Thanks –  user916499 Sep 11 '11 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.