Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Tomcat 7.0.5 (installed with XAMPP 1.7.4) on a Windows XP (virtual machine, if it matters) with JVM version 1.6.0_27-b07.
When I try to upload a WAR file to deploy in Tomcat Web Application Manager ("Select WAR file to upload"), I get the following error message:

Message:    FAIL - File upload failed, no file

I tried to upload two different war-files which do work on another machine (and another server), so I think there's no problem with them.

What can be the possible reasons that lead to this error message?
Thanks in advance!

share|improve this question
up vote 0 down vote accepted

I don't really know why it didn't work on a virtual Windows XP in VirtualBox, but installing XAMPP with Tomcat on a "live" host machine solved the problem. But it would really be good to know why it didn't work on the virtual machine...
Wish Tomcat's documentation wasn't so poor...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.