Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been using an Ubuntu 8.04 server with fail2ban for a while now (12+ months) and using ftp over SSH without any problems. I have a new user that needs to put files onto the server from an IP modem.

I have installed vsftp (sudo apt-get install vsftp) and everything installed correctly.

I have created an ftp user on the server following this guide.

Whenever I try to connect to the server with my ftp program (filezilla) I get an immediate response of:

Connection attempt failed with "ECONNREFUSED - Connection refused by server".

I have looked into fail2ban and cannot find any problems. The iptables setup is:

Chain INPUT (policy ACCEPT)
target     prot opt source               destination
fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain fail2ban-ssh (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere

VSFTP config file (commented lines removed)

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=[username]
secure_chroot_dir=/var/run/vsftpd
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key

Any ideas on what is preventing access to the server?

share|improve this question
    
Can you connect on your ftp server localy from the localhost ? If you can it's probably some firewall issue if not it's vsftpd thing. Also enable logging with xferlog_file=/var/log/vsftpd.log to find out more what is going on. –  golja Jul 12 '12 at 14:13
add comment

2 Answers 2

There's a known issue with vsftp and newer Filezilla versions. I was using that combination for a while, and after a Filezilla update, I found I could no longer connect to my ftp server using ftpes. I think the error message I was getting was different though, but I thought this is worth trying...

http://trac.filezilla-project.org/ticket/7873

"The problem is an incompatibility in the cipher suite that FileZilla is supporting and the cipher suite configured by default on vsftpd... The solution is to add to the /etc/vsftpd.conf :

ssl_ciphers=HIGH

Note, whilst this problem was active, connection via regular FTP was fine.

share|improve this answer
add comment

Set listen to NO. Other than that the config looks good.

share|improve this answer
    
I updated my config listen=NO but I am still getting 'Connection Refused' –  Patrick Sep 15 '11 at 19:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.