Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It takes about 30 seconds for the server to send me the banner, but initial connection is done instantly

only happens when I am at the office, from home it works fine

at the office I have a rRns set-up for my client ip that it's not working.

Server: Exim, public fixed ip, rDNS, no ports blocked, in a datacenter


Config:

hostlist loopback = <; 127.0.0.0/8 ; 0.0.0.0 ; ::1 ; 0000:0000:0000:0000:0000:ffff:7f00:0000/8
hostlist senderverifybypass_hosts = net-iplsearch;/etc/senderverifybypasshosts
hostlist skipsmtpcheck_hosts = net-iplsearch;/etc/skipsmtpcheckhosts
hostlist spammeripblocks = net-iplsearch;/etc/spammeripblocks
hostlist backupmx_hosts = lsearch;/etc/backupmxhosts
hostlist trustedmailhosts = lsearch;/etc/trustedmailhosts
domainlist user_domains = ${if exists{/etc/userdomains} {lsearch;/etc/userdomains} fail}

This happens super fast on the server:

30132 ident connection to 89.238.207.49 failed: Connection refused
30132 sender_fullhost = [89.238.207.49]
30132 sender_rcvhost = [89.238.207.49]
30132 Process 30132 is handling incoming connection from [89.238.207.49]    
30132 host in host_lookup? no (option unset)
30132 set_process_info: 30132 handling incoming connection from [89.238.207.49]
30132 host in host_reject_connection? no (option unset)
30132 host in sender_unqualified_hosts? no (option unset)
30132 host in recipient_unqualified_hosts? no (option unset)
30132 host in helo_verify_hosts? no (option unset)
30132 host in helo_try_verify_hosts? no (option unset)
30132 host in helo_accept_junk_hosts? yes (matched "*")
30132 using ACL "acl_connect"
30132 processing "accept"
30132 check hosts = +trustedmailhosts
30132 sender host name required, to match against lsearch;/etc/trustedmailhosts
30132 looking up host name for 89.238.207.49
30132 IP address lookup yielded relay.easycomm.ro

Client side

2011.09.14 13:08:13 SMTP (mail.server.ro): Begin execution
2011.09.14 13:08:13 SMTP (mail.server.ro): Port: 465, Secure: SSL, SPA: no
2011.09.14 13:08:13 SMTP (mail.server.ro): Finding host
2011.09.14 13:08:13 SMTP (mail.server.ro): Connecting to host
2011.09.14 13:08:13 SMTP (mail.server.ro): Securing connection
2011.09.14 13:08:13 SMTP (mail.server.ro): Connected to host
---> This is a 1 minute 5 seconds gap
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 220-genius.filipnet.ro ESMTP Exim     4.69 #1 Wed, 14 Sep 2011 13:09:26 +0300 
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 220-We do not authorize the use of     this system to transport unsolicited, 
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 220 and/or bulk e-mail.
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] EHLO CatalinDell
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250-genius.filipnet.ro Hello     CatalinDell [89.238.207.49]
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250-SIZE 52428800
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250-PIPELINING
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250-AUTH PLAIN LOGIN
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250 HELP
2011.09.14 13:09:18 SMTP (mail.server.ro): Authorizing to server
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] AUTH LOGIN
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 334 VXNlcm5hbWU6
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] dGVzdEBzcG9ydGd1cnUucm8=
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 334 UGFzc3dvcmQ6
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] *****
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 235 Authentication succeeded
2011.09.14 13:09:18 SMTP (mail.server.ro): Authorized to host
2011.09.14 13:09:18 SMTP (mail.server.ro): Connected to host
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] MAIL FROM: <*****>
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250 OK
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] RCPT TO: <*****>
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 250 Accepted
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] DATA
2011.09.14 13:09:18 SMTP (mail.server.ro): <rx> 354 Enter message, ending with "."     on a line by itself
2011.09.14 13:09:18 SMTP (mail.server.ro): [tx] .
---> This is a 1 minute 10 seconds gap
2011.09.14 13:10:28 SMTP (mail.server.ro): <rx> 250 OK id=1R3mPG-0004T4-7Q
2011.09.14 13:10:28 SMTP (mail.server.ro): End execution

--- Initial info

I've setup an email account on "Windows Live Mail" that comes with Windows 7

Receiving is super fast, but for some reason sending is very slow, I had to increase the outgoing timeout to 3 minutes in order to make it work.

Server software is Exim / Dovecot / cPanel.

Do you have any ideeas why there is a slow sending process?

Thank you!

share|improve this question
1  
Dovecot is not an SMTP server, but an IMAP server. SMTP servers could be Postfix, Exim or Sendmail as the most likely candidates. –  SvW Sep 13 '11 at 12:31
    
you are right! (ofcourse...) I have the exim server –  catalint Sep 13 '11 at 12:46
    
it takes about 30 seconds for the server to send me the banner, but initial connection is done instantly –  catalint Sep 14 '11 at 8:38
    
A typical reason for delayed SMTP is Greylisting. If it is not the case here you have to sniff the traffic to identify the delay. Use tcpdump -s 0 -w dump.pcap to capture the traffic. After that you can open the file on any system with WireShark to analyze it. –  ceving Sep 14 '11 at 9:45
    
I have the same problem, authenticated smtp relaying with Exim is incredibly slow. Unauthenticated (from the LAN the server is in) is fast. So it has to do with the authentication. I never solved it. –  Jasper Sep 14 '11 at 10:08

1 Answer 1

up vote 2 down vote accepted

Without seeing your Exim configuration it's not possible to be certain, however the first line of the log:

30132 ident connection to 89.238.207.49 failed: Connection refused

indicates that your problem is typical of an ident lookup delay. This is documented in the Exim FAQ:

Exim ident calls

Exim SMTP delays

and in Chapter 14 of the Exim documentation. The default value for the ident query delay is 5s, although this was 30s in older versions of Exim.

Check the configuration option and if necessary set it to zero, which disables the calls.

rfc1413_query_timeout = 0s
share|improve this answer
    
hi! sory for the delay, wasn't notified of this answer , 10q , it was 2s set it to 0s but it's still slow, will read the faq-s you linked to –  catalint Nov 2 '11 at 8:58
    
updated my question with a part of config that i think causes the problems –  catalint Nov 2 '11 at 9:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.